
See discussions, stats, and author profiles for this publication at: https://www.researchgate.net/publication/387498939

Reactor Modeling, Convergence Tips and Data-Fit Tool

Chapter · August 2023

DOI: 10.1002/9783527843831.ch3

CITATIONS

12
READS

41

2 authors, including:

Niket Sharma

Aspen Technology, Inc.

20 PUBLICATIONS   278 CITATIONS   

SEE PROFILE

All content following this page was uploaded by Niket Sharma on 29 December 2024.

The user has requested enhancement of the downloaded file.

https://www.researchgate.net/publication/387498939_Reactor_Modeling_Convergence_Tips_and_Data-Fit_Tool?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_2&_esc=publicationCoverPdf
https://www.researchgate.net/publication/387498939_Reactor_Modeling_Convergence_Tips_and_Data-Fit_Tool?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_3&_esc=publicationCoverPdf
https://www.researchgate.net/?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_1&_esc=publicationCoverPdf
https://www.researchgate.net/profile/Niket-Sharma-3?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_4&_esc=publicationCoverPdf
https://www.researchgate.net/profile/Niket-Sharma-3?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_5&_esc=publicationCoverPdf
https://www.researchgate.net/institution/Aspen_Technology_Inc?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_6&_esc=publicationCoverPdf
https://www.researchgate.net/profile/Niket-Sharma-3?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_7&_esc=publicationCoverPdf
https://www.researchgate.net/profile/Niket-Sharma-3?enrichId=rgreq-cafd0074db403369d9947e0804d7b198-XXX&enrichSource=Y292ZXJQYWdlOzM4NzQ5ODkzOTtBUzoxMTQzMTI4MTMwMDQxMjQ1MEAxNzM1NDUwNjMyMTAy&el=1_x_10&_esc=publicationCoverPdf


Reactor Modeling, Convergence Tips and Data-Fit Tool 
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Department of Chemical Engineering, Virginia Polytechnic Institute and State University, 
Blacksburg, Virginia 24061, U.S.A 

 

Abstract 

This chapter provides a comprehensive exploration of kinetic reactor modeling in Aspen Plus/Polymers 
for polyolefin manufacturing, introducing three distinct reactor types: continuous stirred-tank reactors 
(RCSTR), plug-flow reactors (RPLUG), and batch/semi-batch reactors (RBATCH). Detailed configurations 
and specifications of these reactors are examined, alongside methodologies for representing nonideal 
reactor behavior. The chapter presents innovative strategies for optimizing computational efficiency, 
including accelerated solution techniques for conservation equations and phase-equilibrium calculations. 
It further highlights a robust data-fitting tool, enabling regression of critical simulation parameters such 
as reaction kinetics, heat-transfer coefficients, and property model inputs. Practical application is 
emphasized through hands-on workshops demonstrating kinetic parameter estimation using time-
evolution concentration profiles and polymer attribute metrics like number-average and weight-average 
molecular weights. This focused discussion provides actionable insights into advanced reactor modeling 
and parameter optimization, enhancing predictive accuracy and process efficiency for polyolefin 
manufacturing systems.  

This is a preprint version of a chapter from our book - Integrated Process Modeling, Advanced Control 
and Data Analytics for Optimizing Polyolefin Manufacturing. Please cite the original work if referenced 
[12,15] 

 

3.1 Kinetic or Rate-Based Reactors 

We introduce the three types of kinetic or rate-based reactor models available within Aspen 
Plus/Polymers for polyolefin manufacturing, including continuous stirred-tank reactor (RCSTR), plug-flow 
reactor (RPLUG), and batch or semi-batch reactor (RBATCH). We focus on configurations and 
specifications of the three kinetic reactors in Sections 3.2 to 3.4, and on the representation of nonideal 
reactors in Section 3.5. We present practical tips to speed up the solution of mass, energy and polymer 
attribute conservation equations and phase-equilibrium calculations in Sections 3.6 and 3.7. Section 3.8 
discusses the data-fit tool for regressing all types of simulation parameters, such as reaction kinetics, 
heat-transfer coefficients, and any accessible model input parameters (including property model 
parameters). Sections 3.9 and 3.10 cover hands-on workshops applying the data fit for kinetic parameter 
estimation using time-evolution concentration profile and polymer attribute values (such as MWN and 
MWW). Section 3.11 presents the bibliography. 

 

 



Given the reaction kinetics and operating conditions, kinetic reactor models do mass, energy, and 
polymer attribute balance calculations. We note that while Aspen Plus also has a FluidBed reactor 
model, this model can only handle conventional reactions and not polymerization kinetics. In Section 3.5 
and in Chapters 4 to 7, we show how to use the continuous stirred-tank reactor model (RCSTR) to 
represent fluidized-bed reactors in polyolefin manufacturing. We summarize in Table 3.1 the key 
assumptions of the kinetic or rate-based reactors available in Aspen Pus/Polymers: 

Table 3.1 Assumptions of kinetic reactors in Aspen Plus/Polymers 

Reactor type  Assumptions 

RCSTR Ideal mixing; homogeneous concentrations inside the reactor; constant 
temperature and pressure; phase equilibrium 

RPLUG Ideal plug flow of fluids without backmixing; homogeneous in the radial direction; 
phase equilibrium; allows cocurrent or countercurrent heating 

RBATCH Ideal mixing; homogeneous concentrations; constant temperature; constant 
pressure at each time step; phase equilibrium; Permit a single charge or                          

time-varying feeds; feed and product stream conditions are time-averaged 

FLUIDBED Ideal solid mixing; plug-flow vapor phase; homogeneous in the radial direction; 
continuous feeds of vapor and solids 

 

3.2 Continuous Stirred-Tank Reactor (RCSTR)                                                                                                                       
3.2.1 RCSTR Configurations 

We use RCSTR in our slurry HDPE process as showcased by Sharma et. al. [9,17] for modeling polyolefin 
kinetics.A CSTR model can have a single or multiple feeds. Depending on the valid phases that we set, 
the model can have a single liquid or vapor product (valid phases = liquid only, or vapor only), a vapor 
product and a liquid product (valid phases = vapor-liquid), and a vapor product and two liquid products 
(valid phases = vapor-liquid-liquid). Figure 3.1 illustrates these configurations, in which we can replace 
the single feed with multiple feeds. Note for RCSTR3, we have added the optional input and output 
“heat” streams. Figure 3.2 shows where we set the valid phases and key component of the 2nd liquid 
phase. 

 

Figure 3.1 RCSTR configurations 



 

Figure 3.2 Specification of valid phases and key component of 2nd liquid phase. 

3.2.2 RCSTR Specifications 

Figure 3.3 illustrates the specifications of a CSTR D201 in Workshop 5.1 for a slurry HDPE process. 

 

Figure 3.3 Specifications of a RCSTR 

For operating pressure, we can specify an exit pressure (value positive) or a pressure drop (value zero or 
negative), and we can enter an exit temperature or a reactor heat duty. For phase, we can specify vapor 
phase or condensed phase. This chosen phase determines the specification type for the holdup input. 
Specifically, we may select one of seven types: (1) reactor volume, (2) residence time, (3) reactor volume 
and phase volume, (4) reactor volume and phase volume fraction, (5) reactor volume and phase 
residence time, (6) residence time and phase volume fraction, and (7) phase residence time and volume 
fraction. We will demonstrate the specifications of kinetics and component attributes beginning in 
Chapter 4, and RCSTR convergence tips in Section 3.5. 

3.3 Plug-Flow Reactors (RPLUG) 

3.3.1 RPLUG Configurations 

We use RPLUG in our high-pressure LDPE process and EVA (ethylene-vinyl acetate copolymer) process in 
Chapter 4. Figure 3.4 illustrates a RPLUG configuration with valid phases of vapor-liquid-liquid. To 
specify the valid phases, follow the path: Simulation -> Setup -> Global settings -> Valid phases -> Vapor-



liquid-liquid. We follow the same path when specifying the valid phases for RPLUG to be vapor only, 
liquid only, or vapor-liquid. 

A distinct feature of the RPLUG model is the ability to use a heat-transfer fluid (HTFL) or a thermal fluid. 
We see in Figure 3.4 the inlet and outlet HTFL streams, HTFLIN and HTFLOUT. 

                                                                                 
Figure 3.4 RPLUG configuration with heat-transfer fluid (HTFL). 

3.3.2 RPLUG Specifications 

Following the path: Simulation -> Blocks -> RPLUG -> Setup -> Reactor type-> We see the following 
options available to a thermal fluid in Figure 3.5:          

 

Figure 3.5 Available reactor types for RPLUG 

For RPLUG with a thermal fluid, we see five possible options: (1) constant thermal fluid temperature; (2) 
co-current thermal fluid; (3) counter-current thermal fluid; (4) specified thermal fluid temperature along 
the reactor length; and (5) specified external heat flux profile. In the figure, we also see two common 
reactor types: (1) constant specified temperature; and (2) adiabatic reactor. For a RPLUG with a co-
current or a counter-current thermal fluid, Figure 3.6 shows two additional specifications: (1) heat-
transfer coefficient of the thermal fluid; and (2) thermal fluid outlet temperature. In Chapter 4, we use 
the RPLUG model with a thermal fluid in the simulation of a high-pressure LDPE process with tabular 
reactors. 

 

Figure 3.6 Specifications of heat-transfer parameter and thermal fluid outlet temperature. 



Next, we see the configuration specifications in Figure 3.7. 

 

Figure 3.7 Configuration specifications of the RPLUG 

The Streams folder specifies the products, with VAPOR being vapor phase, LIQUID1 being 1st liquid phase 
and LIQUID2 being 2nd liquid phase. We will give the details of Reactions specification beginning in 
Chapter 4. The Pressure folder specifies the pressure at reactor inlet, and the pressure drop. For the 
Holdup folder, we typically stay with the default condition, assuming no slip between phases. 

3.4 Batch Reactor (RBATCH) 

3.4.1 RBATCH Configuration 

The RBTCH model can simulate a batch or a semi-batch operation. We use RBATCH in our SBS (styrene-
butadiene-styrene rubber) process in Chapter 7. Figure 3.8 shows a RBATCH configuration. In the figure, 
BCHARGE represents a single batch charge stream (required). CFEEDs represents one or more 
continuous feed streams for semi-batch operation (optional). Product represents a single product 
stream (required). VENT represents a vent stream for semi-batch operation (optional). There is no inlet 
heat stream, and an optional outlet heat stream is allowed.  

RBATCH performs mass, energy, and polymer attribute conservation calculations around an ideal batch 
reactor, assuming known reaction kinetics and the reactor contents to be well-mixed. 

 

Figure 3.8 RBATCH configuration 

3.4.2 RBATCH Specifications 

Figure 3.8 illustrates the six options for reactor operating specifications. Choosing each option will lead 
to additional required specifications: (1) constant temperature – operating temperature; (2) 
temperature profile – time versus operating temperature; (3) constant heat duty – heat duty; (4) heat 
duty profile – time versus heat duty; (5) constant thermal fluid temperature – thermal fluid 
temperature, overall heat-transfer coefficient, and heat-transfer area; and (6) heat-transfer user routine 



– see an example for specifying a heat-transfer user routine in Chapter 4 for our high-pressure LDPE 
reactor (which is a continuous reactor but with essentially similar user subroutine specifications). 

 

Figure 3.9 Six options for RBATCH operating specifications 

In the figure, we see the pressure specification. Three options are available: (1) specify reactor pressure; 
(2) specify reactor profile (time versus operating pressure); and (3) calculate reactor pressure. Figure 
3.10 illustrates the temperature profile, “calculate reactor pressure” specification, and valid phases. We 
need to provide the reactor volume to calculate the reactor pressure. When allowing a vent stream 
during a semi-batch operation, we specify a vent opening pressure together with the reactor volume. In 
the figure, we also see the specification folders of “Stop Criteria”, “Operating Times” and “Continuous 
Feeds”, which we will illustrate in detail in our SBS process in Chapter 6. See Table 6.13 and Figures 
6.79a to 6.79c. 

 

Figure 3.10 Temperature profile, “Calculate reactor pressure” specification and valid phases. 

Lastly, we see the specification folder of “Controllers” in Figure 3.10. RBATCH performs controller -
calculations if temperature or temperature profile is specified and the reactor is semi-batch with 
continuous feeds, has vapor and liquid phases, and is venting with constant volume. A search of 
“RBATCH controllers” in the Aspen Plus online help gives details of the PID (proportional-integral-
derivative) controllers for reactor temperature and pressure. We discuss in detail in Chapter 7 about 
controller specifications and tuning. 

3.5 Representation of Nonideal Reactors 

This section gives examples where we can use the RCSTR model to represent nonideal reactors in 
industrial manufacturing of polyolefins. 



In Section 5.6.4, we discuss the role of solid polymer in phase-equilibrium calculations using a slurry 
HDPE process as an example. We assume that the polymer is dissolved in the liquid phase with the 
solvent, as would be the case in solution polymerization of ethylene, where the reactor temperature 
would be above the melting point of the polymer.  Although this modeling simplification does not 
represent the physical picture of what is happening in the slurry polymerization of ethylene, the effect 
of it on thermodynamic modeling is relatively small.  Figure 5.25 illustrates the difference between the 
actual conditions and the modeling assumption [3]. 

In Section 5.7.3, we discuss in detail the modeling of a horizontal stirred-bed reactor for a gas-phase PP 
process using a series of four RCSTRs [1]. See Figure 5.50. Experimental studies on the residence-time 
distribution (RTD) of polymers produced in horizontal stirred-bed reactors suggest that the polymer RTD 
is equivalent to that produced by three to five CSTRs [2].   

Figure 5.8 shows a Univation UNIPOL LLDPE process using a fluidized-bed reactor. Current practice is to 
model UNIPOL and similar fluid-bed reactors as RCSTRs in Aspen Plus. The fluidizing solid polymer phase 
behaves like a fluid from a phase-equilibrium point of view. Referring to Figure 3.3, we need to specify 
the volume holdup of the condensed phase based on the known inventory of solids in the bed. 

3.6 RCSTR Convergence 

Figure 3.11 shows the RCSTR convergence scheme shown in the Aspen Plus online help. We follow this 
figure and discuss the details of each step below  

Figure 3.11 Convergence scheme of RCSTR 

3.6.1 Initialization 

To initialize the mass, energy, and polymer attribute conservation calculations, the default method is 
called the solver method. Specifically, RCSTR sets outlet stream equal to inlet stream, or uses specified 
estimates of temperature, component flow rates and attribute values, to initialize the RCSTR block, 
unless previously converged results are available. RCSTR then solves the mass, energy and polymer 
attribute conservation equations by a trial-and-error technique based on the initial guess. 



An alternative initialization scheme is the integrator method, in which RCSTR integrates the mass, 
energy and polymer attribute conservation equations numerically from an initial condition to the 
steady-state condition.  By default, the initial condition refers to setting the outlet stream equal to the 
inlet stream, temperature to the specified temperature, or heat duty equal to the specified heat duty. 
When using this method, we do not supply estimates of component flow rates and attribute values. 

We follow the path: Simulation -> Blocks -> RCSTR Block -> Convergence -> Parameter -> Initialization -> 
Choose: (1) Do not use integration; (2) Always use integration; or (3) Initialize using integration. See 
Figure 3.12. 

 

Figure 3.12 An illustration of initialization options. 

Aspen Plus online help suggests that “numerical integration is more reliable than trial-and-error 
solvers”. Therefore, when troubleshooting mass-balance convergence problems, consider deleting initial 
estimates and initializing using integration.  

3.6.2 Scaling Factors 

Scaling factors have a strong influence on the RCSTR convergence behavior. Basically, Aspen Plus uses 
numerical solvers to solve the mass, energy, and polymer attribute conservation equations and to 
converge on recycle loop calculations in the kinetic reactors, including RCSTR. The solver algorithms use 
scaled variables. Ideally, the scale factors for each type of variable should be on the same order of 
magnitude as the variable itself (e.g., mass fraction from 0 to 1; polymer attribute MWN from 5,000 to 
60,000). In other words, the solvers work best when the scaled variables are close to unity. We note that 
if the scaling factors are large and the variables are small, then the model will be loosely converged; if 
the scaling factors are small and the variables are large, then the convergence criteria would be 
unacceptably tight, leading to model convergence failure. 

Clicking on “Advanced Parameters” button displayed in Figure 3.13 leads us to two scaling parameter 
options: component-based and substream-based. Interested readers may search in Aspen Plus online 
help for “Component Attributes Scale Factors” for additional details. For substream-based scaling, 
search for “Substream Mixed and Stream Class CONVEN” to understand how Aspen Plus arranges 
component mole flows, total mole flow rate, temperature, pressure, mass enthalpy, …component 
attributes for polymer (e.g., SFRAC, MWN, MWW, PDI, …), into a substream vector MIXED for 
conventional components. Sharma et. al. used this convergence strategy for modeling HDPE and PP 
processes. 



Table 3.2 lists the guidelines on how Aspen Plus determines the scaling factors by the RCSTR 
component-based and substream-based methods. Note the trace scaling factor displayed in Figure 3.12. 
When this factor equals 1, both component-based and substream-based scaling methods are identical. 

 

Figure 3.13 Scaling parameter options: component-based and substream-based. 

 

 

 

Table 3.2 Guidelines for RCSTR component-based and substream-based scaling factors 

Variable type Component-based scaling Substream-based scaling 
Enthalpy Estimated outlet stream enthalpy 10E5 
Component mole 
flows 

The larger of: (1) Estimated mole flow in the 
outlet stream; (2) (Trace scaling factor 
between 0 and 1)*(Total estimated flow rate 
of the outlet stream) 

Total estimated mole 
flow rate of the outlet 
stream  

Conserved polymer 
attributes 

The larger of : (1) Estimates value in the 
outlet stream; (2) (Default attribute scaling 
factor)*(Estimated component mole flow); 
and (3) (Trace scaling factor)*(total 
estimated mole flow)*(default attribute 
scaling factor) 

Default attribute scaling 
factors 

 

3.6.3 Residence Time Loop 

In Figure 3.3, we have provided the reactor volume and phase volume. If we choose to specify the 
residence time, instead of volume, RCSTR adjusts the volume to satisfy the residence time specification. 
We can alleviate the convergence problem in the residence time loop by providing initial volume 
estimates. We follow the path: RCSTR -> Convergence -> Estimates -> Volume: fill in estimates of reactor 
volume. If convergence problems persist, we change the maximum volume step by following the path: 



RCSTR -> Convergence -> Parameters -> Volume Convergence -> Maximum Volume Step -> Reduce from 
1 to a smaller value. See Figure 3.14. 

 

Figure 3.14 Reducing the maximum volume step parameter to speed up residence to loop convergence 

When troubleshooting convergence problems, Aspen online help recommends that we simplify the 
problem by specifying temperature and volume, instead of heat duty and residence time. 

3.6.4 Energy Balance Loop 

In the energy balance loop, RCSTR adjusts the reactor temperature to match the specified reactor heat 
duty. If we specify the reactor temperature, instead of the reactor heat duty, RCSTR bypasses this loop, 
and move on to the mass balance loop, thus greatly simplifying the mass and energy balance 
calculations. This also suggests that when it is feasible, simply the RCSTR (and RPLUG and RBATCH) 
calculations by specifying the reactor temperature, instead of het duty or heat-transfer parameters 
(thermal fluid temperature, overall heat transfer coefficient, or thermal fluid stream). 

We note that the reaction rates are sensitive to temperature, and any large changes in the reactor 
temperature may cause the energy balance loop to diverge.  

If we follow the path to specify both pressure and heat duty as the reactor operating conditions: 
Simulation -> Blocks -> RCSTR -> Setup -> Operating conditions -> specify pressure and heat duty, we 
may avoid reactor convergence problem by providing a good temperature estimate. We do this by 
following the path: Simulation -> Blocks -> RCSTR -> Convergence -> Estimates -> Temperature: fill in the 
estimate. If the convergence problem persists, we could reduce the maximum temperature step size 
from the default of 50°C to a smaller value. See Figure 3.15. 

 

Figure 3.15 Energy balance convergence: reducing the maximum temperature step size. 

3.6.5 Mass Balance Loop 



RCSTR has two solvers to converge the mass, energy and polymer attribute conservation equations for 
component mole flow and conserved component attributes (e.g., SFRAC, MWN, MWW, etc.): (1) 
Broyden algorithm: tends to be relatively fast, but may be unstable if the number of components and 
attributes is large, and the reaction rates are high; and (2) Newton algorithm: tends to be slower, but 
more stable for many classes of problems.  

Before we talk about the number of mass-balance iterations to achieve convergence for each algorithm, 
let us see Figure 3.16 and understand the concept of damping [4]. Process simulation software tools 
typically include provisions to apply a damping factor to reduce the ratio of the root-mean-squared 
(RMS) error of process variables to the error tolerance to less than 1 within a finite number of iterations 
and thus achieve convergence. This figure illustrates how this ratio reduces to less than 1 (i.e., 100) 
within a finite number of iterations in a well-damped system after applying a damping factor, and how 
this ratio grows in an under-damped system. 

 

Figure 3.16 An illustration of the concept of damping 

Figure 3.17 shows that the default number of iterations for the mass-balance convergence solver, the 
Broyden algorithm, is 50. This default is sufficient for the Newton algorithm, but is usually too small for 
the Broyden algorithm. This is illustrated in Figure 3.17, where Aspen Plus online help recommends 
increasing the number of iterations for the Broyden algorithm for polymer process simulation to at least 
500, and to apply a small damping factor between 0.1 and 0.001 (accessed by clicking on the “Advanced 
Parameters” button displayed in the figure). 

 

Figure 3.17 Setting the maximum number of iterations for the Broyden algorithm to 500 and adding a 
small damping factor on mass balance variables between 0.1 and 0.001. 



When using the Newton algorithm for mass-balance iterations, applying a stabilization strategy to 
specify the method used to stabilize the Newton algorithm. There are two options: (1) dogleg strategy 
(default) that uses Powell's dogleg strategy in optimization theory to combine Newton and steepest 
descent directions; and (2) line search strategy that uses one-dimensional search along Newton 
direction. Line search is recommended for polymerization kinetics and systems where reaction rates are 
sensitive to the concentrations of trace species which are also reacting (such as reacting catalysts or 
inhibitors). Changing the stabilization strategy within “Newton Parameters” from “dogleg” to “line 
search” could improve the convergence behavior, especially for ionic and Ziegler-Natta polymerization 
kinetics. See Figure 3.18. 

 

Figure 3.18 Changing the stabilization strategy to “line search” to improve mass-balance convergence. 

3.6.6 Flash Loop 

As illustrated in Figure 3.11, we see from the bottom up that the flash loop is the inner-most loop, while 
the energy balance loop and the residence time loop represent the outer loops. The flash loop does the 
phase-equilibrium calculations. It is essential to have accurate physical properties over the entire range 
of temperatures and pressures found in the process. When we see the message of “initial flash failure” 
in the control panel, this is likely the result of a physical property problem. Check the heat of formation 
(DHFORM) and the ideal gas heat capacity (CPIG) of the polymer and oligomer components. If these 
property values are missing, apply the property estimation methods of Chapter 2 (see Section 2.7). If a 
supercritical component (light gases and low molecular weight hydrocarbons) is present, consider 
treating them as Henry components when using the POLYNRTL property method (see Section 2.2.5). 
When flash failures appear during the mass-balance loop, change the parameters of flash options by 
following the path: Simulation -> Blocks -> RCSTR -> Convergence -> Flash options > Increase “maximum 
iterations” to 200, and decrease flash tolerance to less than 0.0001. 

3.6.7 Recommendation for RCSTR Mass-Balance Algorithm for Polyolefin Process Simulation 

Table 3.3 summarizes the recommended RCSTR mass-balance convergence algorithms for polyolefin 
process simulation. 

Table 3.3 Recommendations for RCSTR mass-balance convergence algorithms 



Polyolefin 
Polymerization 
Kinetics 

RCSTR Mass-Balance Convergence 
Algorithm 

1. Free radical 
polymerization 
(Chapter 4: LDPE, 
EVA; Chapter 7, PS) 
[16,19] 

Use Broyden for homopolymerization, 
assuming pseudo steady state 
approximation (PSSA); otherwise, use 
Newton. 

2. Ziegler-Natta 
polymerization 
(Chapter 5: HDPE, 
PP, LLDPE); and 
ionic 
polymerization 
(Chapter 7: SBS) 
[17,19] 

Use Newton with estimates. If this fails, 
initialize with integration. Reduce the default 
trace scaling factor of 0.0001 (see Figure 
3.12) by a factor of 10 if trouble persists. 
Change the stabilization strategy from 
“dogleg” to “line search”. 

 

3.7 RPLUG/RBATCH Convergence 

The convergence calculations of both RPLUG and RBATCH are essentially similar. They use a variable-
step Gear integration scheme [5] to solve the mass, energy, and polymer attribute conservation 
equations. For RPLUG, we integrate along the reactor length, and for RBATCH, we integrate along the 
time axis. Figure 3.19 shows the identical “flash options” for both RPLUG and RBATCH. 

 

Figure 3.19 Flash options for both RPLUG and RBATCH 

Figure 3.20 illustrates the “integration loop” of RPLUG. 

 

Figure 3.20 Integration loop of RPLUG. 



For both RPLUG and RBATCH, the solver algorithm of mass, energy and polymer attribute conservation 
calculations is called the corrector. Two corrector methods are available to RPLUG and RBATCH: (1) 
Direct - direct substitution method; and (2) Newton method. In general, Newton method is best 
performance with polymerization kinetics; but for problems with a large number of variables, the direct 
method is faster. Aspen Plus online help suggests trying both methods to see which is faster for a 
specific problem. 

In Figure 3.20, we see an “initial step size of integration variables” of 0.01. If the solver cannot converge 
the equations with this step size, it will cut the step size by a factor of ten. This process will repeat up to 
six time. If the solver still cannot converge, the reactor calculation fails with an error message “solver 
cannot converge with minimum step size”. When this occurs, we recommend reducing the initial step 
size to as low as 1E-4. 

Figure 3.20 also shows a “maximum number of integration steps” of a default value of 1000. For kinetics 
with fast reactions involving trace components, especially when the corrector uses the direct 
substitution method, Aspen Plus online help recommends increasing the maximum number of 
integration steps from 1000 to 5000. If more than 5000 steps are required for convergence, try replacing 
the corrector method to Newton. 

We see in Figure 3.20 that for RPLUG, a default “error tolerance ratio” of 0.1. This means that the 
corrector tolerance is 1E-5, that is, 0.1 times the integration convergence tolerance (set at 0.0001). For 
some problems, especially those involving RPLUG with heat-transfer calculations, the error tolerance 
ratio may be higher than 0.1, but it should always be less than 1. For RBATCH, we do not see the entry of 
error tolerance ratio within the integration loop, but it has a hidden default value of 0.1. 

Like RCSTR, RPLUG and RBATCH solve the mass, energy and polymer attribute conservation equations 
using scale factors discussed in Section 3.6.2. In Figure 3.20, we see the entry of error scaling method. 
Both RPLUG and RBATCH have two options: (1) Static scaling factors based on the feed steam conditions 
and they are held constant throughout the integration process; and (2) Dynamic scaling factors, which 
are updated at each integration step based on previous variable values.  In Figure 3.20, we see in the 
integration loop of RPLUG an entry of “minimum scale factor” with a default value of 1E-10. When 
running RPLUG simulation, we may encounter an error message of “integration error: maximum number 
of integration steps is reached”. This may happen with dynamic scaling when a variable value becomes 
so small that small absolute error becomes large, scaled errors.  The solution is to increase the minimum 
scale factor from the default value of 1E-10 to 1E-5. 

This concludes our general discussion of guidelines for reactor convergence tips. In an application 
involving dynamic data, Sharma et al. [10] demonstrated the use of RBatch to simulate polymer data, 
facilitating advanced data analysis. In Chapters 4 to 7, we illustrate the applications of these guidelines 
to specific industrial polymerization reactors with different polymerization kinetics, and discuss the 
practical guidelines for flowsheet convergence involving reactors, separators, and other units. 

3.8 Data Fit (Simulation Data Regression) 

In Section 2.7, we discussed the data regression (DRS) tool to estimate thermophysical properties and 
pure component and binary interaction parameters for property methods. Aspen Plus has another 
useful tool for simulation data regression, called data fit. We can use it to: (1) estimate unknown model 



parameters (e.g., reaction kinetic parameters, heat transfer coefficients, separation efficiencies, etc.); 
(2) reconcile measured data; and (3) estimate unknown model parameters and reconcile measured data 
simultaneously. 

Data fit is an efficient nonlinear regression tool that allows the user to determine statistically acceptable 
model parameters from constant, or time-varying, or temperature-dependent laboratory 
measurements, or from matching the process simulation to plant targets. We can use either point data 
or time-profile data for regression. We need to define the data with reconciled input variables and a 
standard deviation. We estimate the model parameters using the data within the specified range [6]. 

The least-square regression objective function that the data fit minimizes is as follows: 
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subject to                                 𝑋௣௟௕ ≤  𝑋௣ ≤  𝑋௣௨௕ ,  𝑋௥௜௟௕ ≤  𝑋௥௜ ≤  𝑋௥௜௨௕                                 (3.2) 

where: 

          Nset = Number of datasets specified for regression 

          Nexpi = Number of experiments in dataset i 

          Nri = Number of reconciled input variables 

          Nrr = Number of measure output variables 

          Wi = Weight for each dataset i for regression 

           Xp = Vector of varied parameters 

          Xmri = Measured values of the reconciled input variables 

          Xri = Calculated values of the reconciled input variables 

          Xmrr = Measured values of the output variables 

          Xrr = Calculated values of the output variables 

          σ = Standard deviation specified for the measured variables 

Since the model parameter estimation is a complex regression problem, we can vary some numerical 
parameters within the data fit to speed up the convergence calculations. We vary the maximum 
algorithm iterations and the maximum number of passes through the process flowsheet which are 
required to compute the residuals. We specify a bound factor which gives the upper and lower bounds 
for variables by multiplying by the standard deviation. We also specify the absolute sum of squares 
objective function tolerance, so that the problem converges whenever the objective function value is 
less than the tolerance value. 

The tool performs the least-square regression using a trust region algorithm for parameter estimation. 
Specifically, the algorithm maintains an estimate of the diameter of a region, called the trust region, 
about the current estimate of the vector of varied values in which it can predict the behavior of the 



least-squares objective function. If an adequate model is found within the trust region, the region is 
expanded; if the model is a poor approximation, then the trust region is contracted. The tool also 
provides certain handles to implement the regression with the trust region optimization algorithm.  

Sharma et al. [9] utilized this regression strategy to estimate the kinetics of polyolefin processes. 
Similarly, McNeeley et al. [11] employed the regression tool to estimate the kinetics of nylon 
depolymerization. 

 

3.9 Workshop 3.1 Data Fit of Kinetic Parameters for Styrene Polymerization Using Concentration 
Profile Data 

3.9.1 Objective 

The objective of this workshop is to demonstrate the steps involved in applying data fit tool to regress 
kinetic parameters for simplified styrene bulk polymerization by thermal initiation [7,8]. This is an 
example of free radical polymerization, which we discuss detail in Chapters 4 for LDPE and EVA 
(ethylene-vinyl-acetate copolymer), and in Chapter 6 for polystyrene (PS). For this workshop, we begin 
with a simplified simulation model for PS, explain the completed steps, and then demonstrate the step-
by-step application of the data fit tool in order to regress the kinetic parameters of the polymerization 
reactions based on time-dependent evolution of PS concentration in a batch reactor. Our starting 
simulation file for the workshop is: WS 3.1 Data Fit_Profile Data_PS.bkp. 

3.9.2 A Simplified Kinetic Model for Styrene Polymerization 

We open the starting simulation file and go to the Properties environment. The Setup folder shows that 
this example uses a unit set METCBAR built from a MET unit set by changing the temperature unit from 
K to °C, and pressure unit from atm to bar, as demonstrated previously in Figure 1.7a. 

Next, we go to the Components folder, and see the following specifications: 

 

Figure 3.21 Component specifications 

Here, STY and STE-SEG are styrene monomer, and styrene segment (repeat type). PS is the polystyrene 
product. INIT is the chain initiator, di-t-butyl-peroxide (DTBP), which is available within the Aspen 
Polymers initiator databank. CINI is a co-initiator, which is a hypothetical component required to 
activate the thermal initiator reaction in the free radical polymerization kinetic model of Aspen 
Polymers. EB (ethylbenzene) is a chain-transfer agent to control the molecular weight. INHIBIT is an 
inhibitor, which is represented by STY. 



We click on the “Enterprise Database” button displayed in Figure 3.21 to ensure that we have included 
databanks for pure components, segments, polymers and initiators for this example. See Figure 3.22. 

 

Figure 3.22 Specified enterprise databases 

Next, we follow the path: Properties -> Components -> Polymers -> (1) Segments: segment ID = STY-SEG, 
type = Repeat; and (2) Polymers: Polymer ID: Choose “PS”; Built-in attribute group: Choose “Free radical 
selection”. 

This workshop uses the POLYNRTL property method discussed in Section 2.2.4. Follow the path: 
Properties -> Methods -> Specifications -> Global -> Method name: Choose POLYNRTL. 

Next, we click on the “Review” bottom displayed in Figure 3.21 to call up the pure component 
parameters. We see the resulting pure component parameters by following the path: Properties-> 
Methods -> Parameters -> Pure Components.  

To ensure that PS has an extremely small liquid vapor pressure and does not vaporize, we enter the first 
temperature-dependent parameter for the extended Antoine correlation for liquid vapor pressure 
(PLXANT-1) for PS as -40. See Figures 3.23. To see the specific equation for the PLXANT correlation, click 
on the “Help” button displayed in Figure 3.23 to see the extended Antoine correlation. 

 

Figure 3.23 Specification of user parameter for liquid vapor pressure correlation for PS 

Following Section 2.3, Workshop 2.1, we estimate all the missing binary interaction parameters for the 
POLYNRTL model using the UNIFAC group contribution method. We follow the path to see the estimated 
parameters: Properties -> Methods -> Parameter -> Binary Interactions -> NRTL-1 (see Figure 3.24). After 
this estimation, we follow the path to discontinue this estimation step in the next simulation: Properties 
-> Estimation -> Input -> Setup -> Estimation options: choose “Do not estimate any parameters”. 



 

Figure 3.24 Estimated POLYNRTL binary interaction parameters 

Next, we go to the simulation environment, and see the flowsheet of the RBATCH reactor in Figure 3.25. 

 

Figure 3.25 RBATCH reactor for WS 3.1 

The FEED steam is at 100°C and 4.5 bar, and the component mass flow rates (kg/hr) are: STY= 1000; 
INIT= CINIT = 1; EB = 5; and INHIBIT= 0.5. 

We discuss in more detail in Chapter 4 about the kinetics of free-radical polymerization. To create our 
reaction set, we follow the path: Simulation -> Reactions -> New -> Create New ID ->Enter ID = R-1; 
Select Type: Free-Rad.-> OK -> Species specification -> See Figure 3.26. 

 

Figure 3.26 Reaction specie specifications. 

For this workshop, we generate the reactions by following the path: Simulation -> Reactions -> Reaction 
R-1a -> Species specification (Figure 3.2) -> Reactions -> Click on “Generate Reactions” button ->  Nine 
reactions listed in Figure 3.27, which includes:  (1) initiator decomposition (Init-Dec) (2) special thermal 



initiation (Init-Sp); (3) chain initiation (Chain-Ini); (4) chain propagation (Propagation); (5) chain transfer 
to monomer (Chat-Mon); (6) chain transfer to chain-transfer agent (Chain-Agent); (7) termination by 
disproportionation (Term-Dis); (8) chain termination by combination (Term-Comb); and (9) inhibition by 
inhibition agent (Inhibition). 

 

Figure 3.22 The generated reaction set for styrene polymerization by thermal initiation. 

In Section 4.2, we will give detailed explanations of each type of free-radical reactions. For the current 
workshop, we focus only on a simplified reaction set by deleting reactions 1 and 7 and enter the initial 
set of rate constants as the initial values for kinetic parameter regression by the data-fit tool. Figure 3.28 
shows the initial rate constants for the remaining seven reactions. 

 

Figure 3.28 Initial rate constants for WS3.1 

 

We note that the reaction rate constants listed in Figure 3.23 have the following standard Arrhenius 
form:  
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where ko is the pre-exponential factor, E is the activation energy, R is the ideal gas constant, and T is the 
temperature of the reaction system and Tr is the reference temperature.  

3.9.3 Datasets 



Our isothermal experimental data from RBATCH include the time evolution of the liquid-phase mass 
fraction of PS (PSFRAC). See Table 3.4. 

 Table 3.4 Time evolution of liquid-phase mass fraction of PS 

 

We create the datasets by following the path: Simulation -> Model Analysis Tools -> Data Fit -> Dataset -
> New -> Enter ID = PS1; Select type = Profile-data -> OK -> (1) Define: See Figure 3.29; (2) Data: See 
Figure 3.30 for dataset PS1 in Table 3.4. Repeat this path to enter datasets PS2 and PS3. 

 

Figure 3.29 Defining the time evolution of the liquid-phase mass fraction of PS as dataset PS1 

 

Figure 3.30 Dataset PS1 

3.9.4 Simulation Data Regression (Data Fit) 

To define a simulation regression run, we follow the path: Simulation -> Model Analysis Tools-> Data Fit 
-> Regression -> New -> Enter ID: R-1 -> OK -> Specifications: (1) Active: yes; (2) Select datasets to be 
regressed: PS1, PS2 and PS3; (2) Vary: New-> See Figure 3.31. Variable 1 (ISPRE-EXP, pre-exponential 
factor for special initiation reaction); Variable 2 (ISACT-Energy, activation energy of special initiation 



reaction); Variable 3 (INPRE-EXP, pre-exponential factor of inhibition reaction).  Define Variable 2 and 
Variable 3 in the same way as Variable 1. 

 

Figure 3.31 Manipulated variables (“Vary”) of simulation data regression R-1 

Figure 3.32 shows the default convergence parameters for data fit: 

(1) Maximum algorithm iterations: Controls the number of regression iterations. 50 runs are more than 
enough (the current run converges in 5 iterations). 

(2) Maximum passes through the flowsheet: For problems with many variables and experiments, 
increase the number of passes. 

(3) Absolute (objective) function tolerance: Usually the default value of 0.01 is too low. 

 (4) Relative function tolerance: Stop iterating when the predicted relative change in the objective 
function falls below the specified value; the default of 0.002 is very tight. Typically, a value of 0.01 (or 
1%) is sufficient. 

(5)  X convergence tolerance: Stop iterating when the predicted maximum relative change in any 
variable is below the specified value; the default value of 0.002 is very tight 

(6) Minimum step tolerance: Controls “solution may be suboptimal message”. The default value is very 
conservative. 

 

Figure 3.32 Default convergence parameters for data fit. 



We follow the path: Simulation -> Model analysis tools -> Data fit -> Regression -> Results -> Summary. 
See Figure 3.33. Here, we look for reasonable improvement from the initial value (14970.5) to the final 
value (122.333) of the objective function. Theoretically speaking, the statistical value of Chi-square 
should be less than the 95% confidence critical value; however, this rarely happens in real regressions. 

 

Figure 3.33 Summary of simulation regression results. 

Next, we check the resulting manipulated variables shown in Figure 3.34. Here, we look for tighter 
bounds between the lower and upper limits of the 95% confidence interval. Wide bounds indicate loose 
fits. Also, make sure that estimated value is reasonably larger than the standard deviation. 

 

Figure 3.34 Estimated manipulated variable values and standard deviations 

A review of the iteration history will also give useful insights. Figure 3.35 shows a good progress 
between iterations in terms of the “objective function” value, and of the actual relative difference 
between the previous and current values of the objective function (called “delta function”). Interested 
readers may search Aspen Plus online help for “Data fit regression results iteration history sheet” for 
explanations of other tabulated results in the figure. 

 

Figure 3.35 Iteration history of data fit run. 

Lastly, we may compare the estimated and measured values by following the path: Regression R-1 -> 
Results -> Fitted Data -> Plot: Choose Custom. X Axis – estimated values; Y Axis – measured value -> OK. 
See the initial plot in Figure 3.361 -> Plot: Format. Choose Squared plot and Diagonal line -> see the 



improved plot in Figure 3.37.                                                             

 

Figure 3.36 The initial plot of estimated value versus measured value. Note the Format options of 
Squared plot and Diagonal line at the top. 

 

Figure 3.37 versus measured data. 

This concludes the current workshop. We save the simulation file as WS 3.1 Data Fit_Profile Data.bkp. 

3.10 Workshop 3.2 Data Fit of Kinetic Parameters for Styrene Polymerization Using Point Data 

3.10.1 Objective: 

The objective of the current workshop is to continue our previous PS workshop and demonstrates how 
to apply data fit tool to regress kinetic parameters for the product stream from the RBATCH reactor to 
meet the required MWN and MWW values at the end of batch polymerization. The dataset for data fit 
run includes only single values of MWN and MWW, which are called point dataset. 

We use the same simulation file as WS3.1 and re-save it as WS 3.2 Data Fit_ Point Data_PS. Bkp. We 
follow the path: Simulation -> Streams -> Product -> Result -> Component Attributes -> MWN = 2792.19, 
and MWW = 5483.05 (see Figure 3.38). Our task is to find the appropriate pre-exponential factors for 



rate constants for chain propagation reaction and chain-transfer-to-monomer reaction to produce a PS 
product with MWN =2800 and MWW = 5500. 

 

Figure 3.38 Product polymer attributes: MWN and MWW values 

3.10.2 Dataset 

We create the dataset by following the path: Simulation -> Model Analysis Tools -> Data Fit -> Dataset -> 
New -> Enter ID = PS4; Select type = Point-data -> OK -> (1) Define: Variable PSMWN See Figure 3.39 for 
MWN of PS product stream; repeat the same step to define variable PSMWW for MWW of PS product 
stream; (2) Data: See Figure 3.40 for dataset PS4. 

 

Figure 3.39 Defining point-data variables PSMWN and PSMWW 

 

Figure 3.40 Specification of point dataset PS4 

3.10.3 Simulation Data Regression (Data Fit)  



To define a simulation regression run, we follow the path: Simulation -> Model Analysis Tools-> Data Fit 
-> Regression -> New -> Enter ID: R-2 -> OK -> Specifications: (1) Active: yes; (2) Select datasets to be 
regressed: PS4; (2) Vary: New-> See Figure 3.41. Variable 1 (PRPRE-EXP, pre-exponential factor for chain 
propagation); Variable 2 (CMPRE-EXP, pre-exponential factor of chain transfer to monomer).  Define 
Variable 2 in the same way as Variable 1. 

 

Figure 3.41 Manipulated variables for simulation data regression R-2 

Before we run regression R-2, we need to deactivate the previous regression run R-1 by following the 
path: Simulation -> Model Analysis Tools -> Data Fit -> Regression -> R-1 -> Specifications: Cancel the 
“Active” entry. We then run regression R-2 through the control panel. Figure 3.42 shows the regression 
objective function drops from 355881.6 to 1.09908 within two iterations. 

 

Figure 3.42 Summary of simulation regression results 

Figure 3.43 illustrates that the standard deviation for the estimated kinetic parameters is large.  We 
note this is due to the regression of 2 variables using 2 datapoints. From a technical standpoint, the 
regression should be able to perfectly fit the data and a standard deviation should not exist, but one 
does exist due to variable 2 being at its lower bound.  This workshop is simply a demonstration of how 
to use the data fit tool.  Real data fit problems should rely on more datapoints for fitting.  For ‘n’ 
variables, a minimum of ‘n’ datapoints are required and ‘n+1’ datapoints are required for a standard 
deviation to exist.  Results that are statistically significant require a number of datapoints that is at least 
an order of magnitude greater than the number of regressed variables.  Figures 3.44 and 3.45 show 
where you can compare fitted data to regression estimated data and objective function iteration results. 



 

Figure 3.43 Estimated manipulated variables and standard deviations 

 

Figure 3.44 Comparison of measured value and estimated value. 

 

Figure 3.45 The objective function drops significantly within two iterations. 

We conclude the current workshop and save the simulation file as: WS 3.2 Data Fit_ Point Data_PS. 
Bkp. This chapter is published with Wiley publication in the book Integrated Process Modeling, Advanced 
Control and Data Analytics for Optimizing Polyolefin Manufacturing by Liu & Sharma. [12-23] 
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